Installer Antidote sur Ubuntu

De Octet.ca

Cet article explique comment installer le logiciel de correction grammaticale Antidote RX sur Ubuntu, pour les versions 9.10 et ultérieures.

Sommaire

[modifier] Étapes à suivre

[modifier] Retirer toutes les installations d'Antidote déjà présentes

Pour éviter des ennuis, il faut retirer l'installation précédente que vous avec déjà fait d'Antidote.

[modifier] Paquets supplémentaires à installer

Il est possible d'installer le paquet kdelibs' et pour libstl, directement:

 sudo apt-get install kdelibs libstlport4.6ldbl libstlport5.2 libstlport4.6-dev

[modifier] Installation d'Antidote RX

Pour démarrer l'installation à partir du CDROM, il faut exécuter la commande:

sudo /media/cdrom/Linux/Installe\ Antidote

Choisir la distribution Ubuntu (autre). Cliquez sur oui pour installer le logiciel, même si cette distribution n'est pas supportée.

Survient alors l'erreur:

Certains paquets dont dépend Antidote ne sont pas installés.

Les paquets suivants sont nécessaires au bon fonctionnement d'Antidote:

libstlport4.6c2

Ensuite l'option est offerte pour les télécharger sur internet. Si on clique sur le bouton « Télécharger et installer les paquets », la même fenêtre d'erreur s'affiche.

L'autre option est celle d'ignorer l'erreur et de « Tenter l'installation », ça devrait fonctionner.

[modifier] Erreur libdbus-glib-1.so.2

En démarrant Antidote par la suite, on obtient l'erreur:

Antidote
Antidote: symbol lookup error: /usr/lib/libdbus-glib-1.so.2: undefined symbol:  dbus_watch_get_unix_fd

Il faut simplement d'effacer un fichier de la nouvelle installation:

 sudo rm /usr/local/Druide/Antidote/lib/libdbus-1.so.3

[modifier] Enregistrement

Par la suite, on peut démarrer en tant que root pour enregistrer le logiciel:

sudo Antidote

Pour obtenir un code, on peut se rendre sur la page de Druide informatique pour se faire.

Ça fonctionne même si la version affichée sur la page n'est pas celle de notre produit. Dans mon cas, c'est l'image pour Antidote HD mais j'ai la version RX.

[modifier] 12.04 Precise Pengolin

Les liens symboliques sont brisés. Il faut faire:

sudo rm /usr/local/Druide/Antidote/lib/libssl.so.6
sudo ln -s /usr/lib/i386-linux-gnu/libssl.so.0.9.8 /usr/local/Druide/Antidote/lib/libssl.so.6
sudo rm /usr/local/Druide/Antidote/lib/libcrypto.so.6
sudo ln -s /lib/i386-linux-gnu/libcrypto.so.0.9.8 /usr/local/Druide/Antidote/lib/libcrypto.so.6

Il se pourrait que la librairie libcrypto.so.6. Installer le paquet libcrypto++-dev semble être la solution:

 sudo apt-get install libcrypto++-dev

[modifier] Mise à jour

Il faut par la suite mettre le logiciel à jour. Il faut se rendre sur la page de Druide information:

En date du 9 mai 2010, la mise à jour la plus récente pour GNU/Linux est la version 7. Il faut la télécharger:

wget http://telechargement2.druide.com/telecharger/Linux/antidote_rx/Maj_Antidote_RX_v7_v8_Linux

Par la suite, il faut simplement l'exécuter (le programme va demander le mot de passe root dans une fenêtre):

sudo u+x Maj_Antidote_RX_v7_v8_Linux
./Maj_Antidote_RX_v7_v8_Linux

L'affaire devrait être ketchup après ça.

Outils personnels